スポンサーリンク

050-VBA

L2スイッチのコマンド忘備録!ポートのオン・オフとVLANの設定ができれば日常のメンテナンス程度ならOK?

へっぽこヘタレシステム管理者の管理人です。

管理人の職場のネットワークは、主にアライドテレシスのスイッチを導入しています。

実際には、あまりコンフィグを触る機会はほとんどありませんが・・・

ごくたまに~に、ポートにVLANを設定したりすることがあるので・・・

管理人が使う事があるコマンドを忘備録とてして掲載しておきます。

日常のメンテナンス程度あれば・・・

この程度で事足りるのではないかと思っています。

管理者モード

まずスイッチのコンフィグを触るには・・・

ログイン後に管理者モードに移行する必要があります。

管理者モードに移行するには・・・

enable

を入力します。

ポートやVLANの編集モード

さらにポートやVLANの設定モードに移行するには、

configure terminal

と入力します。

ポートの有効化・無効化

ポートを有効化又は無効化するには・・・

interface port*.*.*
shutdown

又は・・・

interface port*.*.*
no shutdown

と入力します。

【*.*.*】はポートの番号を指定します。

VLANを作る

VLANを作るには・・・

vlan database
vlan 【VLAN_NO】 name 【VLAN_NAME】

と入力します。

VLANを消すには・・・

vlan database
no vlan 【VLAN_NO】
スポンサーリンク

ポートにVLANを追加する【アクセスモード】

ポートにアクセスモードでタグVLANを追加するには・・・

interface port*.*.*-*.*.*
switchport mode access
switchport access vlan 【VLAN_NO】

と入力します。

ポートからタグVLANを削除するには・・・

interface port*.*.*-*.*.*
no switchport access vlan

と入力します。

ポートの範囲を

【*.*.*ー *.*.* 】

と指定することで、複数のポートを同時に設定することができます。

ポートにVLANを追加する【トランクモード】

ポートにトランクモードでタグVLANを設定するには・・・・

interface port*.*.*-*.*.*
switchport mode trunk
switchport trunk allowed vlan add 【VLAN_NO】,【VLAN_NO】,【VLAN_NO】

又は・・・・

interface port*.*.*-*.*.*
switchport mode trunk
switchport trunk native vlan none
switchport trunk allowed vlan add 【VLAN_NO】,【VLAN_NO】,【VLAN_NO】

と入力します。

switchport trunk native vlan none

この一文の有無で、タグ無パケットを通過させるか否か指定できます。

ポートからタグVLANを削除するには・・・

interface port*.*.*-*.*.*
switchport mode trunk
switchport trunk allowed vlan remove 【VLAN_NO】,【VLAN_NO】,【VLAN_NO】

と入力します。

ブログランキングにご協力ください!
ブログランキング・にほんブログ村へ

コンフィグ等の確認

コンフィグの内容を確認するには・・・

管理者モードで・・・

show running-config

と入力します。

スイッチに設定されているVLANを確認するには・・・

show vlan all

と入力します。

ポートのステータスを確認するには・・・

show interface status

と入力します。

ポート毎のVLANを確認するには

show interface switchport

と入力します。

コンフィグのバックアップ取得や流し込み

コンフィグファイルのバックアップを取得したり流し込みを行うには・・・

まずPINGがとおるパソコンに【TFTP】サーバーを立てる必要あります。

パソコンとスイッチ間でPINGが通るようにLANケーブルを接続してから・・・

スイッチにコンフィグを流し混む場合は・・・

awplus# copy tftp flash ↓
Enter source host name []:***.****.***.*** ↓ (TFTPサーバーのIPアドレス)
Enter source file name []:*****.cfg ↓ (ダウンロード対象ファイル)
Enter destination file name [*****.cfg]:(ダウンロード後ファイル名。カッコ内の名前でよければ単にEnter)
Copying...
Successful operation

反対にバックアップを取る場合は・・・

awplus# copy *****.cfg tftp ↓
Enter destination host name []:***.***.***.*** ↓ (TFTPサーバー)
Enter destination file name [*****.cfg]: ↓ (アップロード後ファイル名。カッコ内の名前でよければ単にEnter)
Copying..
Successful operation

と入力します。

忘れていけない設定の反映

スイッチの設定を変更した場合は・・・

必ず再起動時に有効となるように・・・

copy running-config startup-config

と入力することを忘れてはいけません。

ブログ開設に必要なドメイン取得、サーバーレンタル、ASPの登録等は、こちらのサイトから!

スポンサーリンク
スポンサーリンク

-050-VBA

執筆者:


comment

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

CAPTCHA


関連記事

EXCELのVBAを使ってPDFを開き指定のページのみを印刷する!

へっぽこヘタレシステム管理者の管理人です。 さて、昨日に引き続き・・・ ある部署からエクセルのマクロの作成を依頼され・・・ その過程で、いくつか部品を作ったので忘備録として掲載します。 スポンサーリン …

RPA・WinActorの基本操作!アプリケーションの終了と起動!taskkill!

絶賛底辺中の地方公務員の管理人です。 さて、これもすぐに忘れるのですが・・・ WinActorのシナリを作っていると・・・ どうしてもエラー処理で、最終的にアプリケーションを終了させて、再起動する必要 …

RPA・WinActorの練習!暫く使わないとすぐに忘れる!基本操作の習得はエクセルからセクセルの転記から!

物覚えの悪い地方の底辺公務員の管理人です。 今年から、事務の効率化の一環として、RPA・WinActorを使うことになりましたが・・・ 管理人の相場観としては・・・ 手書きの申請書AI-OCRでエクエ …

投票事務・投票録等の書類作成を少しでも簡単にしたい!紙とエンピツと電卓での集計をエクセルを使って簡単にしたい!

超底辺地方公務員の管理人です。 さて、令和3年度の衆議院議員選挙もなんとか終わり・・・ これでようやく予算事務に専念できそうですが・・・ 既に締め切りが迫っており、かなりヤバイです。 間に合うか非常に …

MVNOのSIMでスマホからテザリングでヤフーカーナビを使う!結構な頻度で通信が不安定でナビが動かなくなる!

へっぽこへたれ貧乏ライダーの管理人です。 以前使っていた、バイク用のポータブルナビが・・・ スペースの関係で【Z H2】には取付できなかったので・・・ 悩んだ挙句に、古いスマホをテザリングで接続してヤ …

スポンサーリンク
スポンサーリンク
スポンサーリンク